using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?((0(\.[0-9]+)?)|([1-9]+[0-9]*(\.[0-9]+)?))$";
string input = @"0
1
12
123
0.1
1.12
12.0123
1.23
-1
-12
-0.1
-1.12
-12.0123
-01.23
01.23
3000001230120312030123011.2323
12.
--123
-2323-
23.23.23
34..34";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}