package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-?((0(\.[0-9]+)?)|([1-9]+[0-9]*(\.[0-9]+)?))$`)
var str = `0
1
12
123
0.1
1.12
12.0123
1.23
-1
-12
-0.1
-1.12
-12.0123
-01.23
01.23
3000001230120312030123011.2323
12.
--123
-2323-
23.23.23
34..34`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}