use strict;
my $str = '<img src="https://google.com/animage.jpg" class="google"><img src="https://yahoo.com/animage.jpg"><img src="https://google.com/animage.jpg" class="google"><img src="https://google.com/animage.jpg" class="google"><img src="https://yahoo.com/animage.jpg"><img src="https://yahoo.com/animage.jpg"><img src="https://yahoo.com/animage.jpg">';
my $regex = qr/<\s*\/?\s*img(?![^>]*class=)/p;
my $subst = '$0 class="whatever"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";