import re
regex = re.compile(r"<\s*\/?\s*img(?![^>]*class=)")
test_str = "<img src=\"https://google.com/animage.jpg\" class=\"google\"><img src=\"https://yahoo.com/animage.jpg\"><img src=\"https://google.com/animage.jpg\" class=\"google\"><img src=\"https://google.com/animage.jpg\" class=\"google\"><img src=\"https://yahoo.com/animage.jpg\"><img src=\"https://yahoo.com/animage.jpg\"><img src=\"https://yahoo.com/animage.jpg\">"
subst = "$0 class=\"whatever\""
result = regex.sub(subst, test_str)
if result:
print(result)