re = /<\s*\/?\s*img(?![^>]*class=)/
str = '<img src="https://google.com/animage.jpg" class="google"><img src="https://yahoo.com/animage.jpg"><img src="https://google.com/animage.jpg" class="google"><img src="https://google.com/animage.jpg" class="google"><img src="https://yahoo.com/animage.jpg"><img src="https://yahoo.com/animage.jpg"><img src="https://yahoo.com/animage.jpg">'
subst = '$0 class="whatever"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result