import Foundation
let pattern = #"<\s*\/?\s*img(?![^>]*class=)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<img src="https://google.com/animage.jpg" class="google"><img src="https://yahoo.com/animage.jpg"><img src="https://google.com/animage.jpg" class="google"><img src="https://google.com/animage.jpg" class="google"><img src="https://yahoo.com/animage.jpg"><img src="https://yahoo.com/animage.jpg"><img src="https://yahoo.com/animage.jpg">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0 class="whatever""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)