$re = '/<\s*\/?\s*img(?![^>]*class=)/';
$str = '<img src="https://google.com/animage.jpg" class="google"><img src="https://yahoo.com/animage.jpg"><img src="https://google.com/animage.jpg" class="google"><img src="https://google.com/animage.jpg" class="google"><img src="https://yahoo.com/animage.jpg"><img src="https://yahoo.com/animage.jpg"><img src="https://yahoo.com/animage.jpg">';
$subst = "$0 class=\"whatever\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;