#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<link +?(?:.*?)type="image\/x-icon"(?:.*?)href="(.+?)"(?:.*?) *?\/?>"
Local $sString = "// Below ones must be parsed" & @CRLF & _
"<link rel="icon" type="image/x-icon" href="#" />" & @CRLF & _
"<link rel="shortcut icon" type="image/x-icon" href="#" />" & @CRLF & _
"<link rel="icon" href="#" type="image/x-icon"/>" & @CRLF & _
"<link rel="shortcut icon" href="#" type="image/x-icon"/>" & @CRLF & _
"" & @CRLF & _
"// Below ones must be ignored" & @CRLF & _
"<link rel="search" href="search.html">" & @CRLF & _
"<link rel="help" href="help.html">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")