// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<link +?(?:.*?)type="image\/x-icon"(?:.*?)href="(.+?)"(?:.*?) *?\/?>"#).unwrap();
let string = "// Below ones must be parsed
<link rel=\"icon\" type=\"image/x-icon\" href=\"#\" />
<link rel=\"shortcut icon\" type=\"image/x-icon\" href=\"#\" />
<link rel=\"icon\" href=\"#\" type=\"image/x-icon\"/>
<link rel=\"shortcut icon\" href=\"#\" type=\"image/x-icon\"/>
// Below ones must be ignored
<link rel=\"search\" href=\"search.html\">
<link rel=\"help\" href=\"help.html\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}