re = /<link +?(?:.*?)type="image\/x-icon"(?:.*?)href="(.+?)"(?:.*?) *?\/?>/m
str = '// Below ones must be parsed
<link rel="icon" type="image/x-icon" href="#" />
<link rel="shortcut icon" type="image/x-icon" href="#" />
<link rel="icon" href="#" type="image/x-icon"/>
<link rel="shortcut icon" href="#" type="image/x-icon"/>
// Below ones must be ignored
<link rel="search" href="search.html">
<link rel="help" href="help.html">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end