using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<link +?(?:.*?)type=""image\/x-icon""(?:.*?)href=""(.+?)""(?:.*?) *?\/?>";
string input = @"// Below ones must be parsed
<link rel=""icon"" type=""image/x-icon"" href=""#"" />
<link rel=""shortcut icon"" type=""image/x-icon"" href=""#"" />
<link rel=""icon"" href=""#"" type=""image/x-icon""/>
<link rel=""shortcut icon"" href=""#"" type=""image/x-icon""/>
// Below ones must be ignored
<link rel=""search"" href=""search.html"">
<link rel=""help"" href=""help.html"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}