const regex = /<link +?(?:.*?)type="image\/x-icon"(?:.*?)href="(.+?)"(?:.*?) *?\/?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<link +?(?:.*?)type="image\\\/x-icon"(?:.*?)href="(.+?)"(?:.*?) *?\\\/?>', 'gm')
const str = `// Below ones must be parsed
<link rel="icon" type="image/x-icon" href="#" />
<link rel="shortcut icon" type="image/x-icon" href="#" />
<link rel="icon" href="#" type="image/x-icon"/>
<link rel="shortcut icon" href="#" type="image/x-icon"/>
// Below ones must be ignored
<link rel="search" href="search.html">
<link rel="help" href="help.html">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}