import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<link +?(?:.*?)type=\"image\\/x-icon\"(?:.*?)href=\"(.+?)\"(?:.*?) *?\\/?>";
final String string = "// Below ones must be parsed\n"
+ "<link rel=\"icon\" type=\"image/x-icon\" href=\"#\" />\n"
+ "<link rel=\"shortcut icon\" type=\"image/x-icon\" href=\"#\" />\n"
+ "<link rel=\"icon\" href=\"#\" type=\"image/x-icon\"/>\n"
+ "<link rel=\"shortcut icon\" href=\"#\" type=\"image/x-icon\"/>\n\n"
+ "// Below ones must be ignored\n"
+ "<link rel=\"search\" href=\"search.html\">\n"
+ "<link rel=\"help\" href=\"help.html\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}