# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<link +?(?:.*?)type=\"image\/x-icon\"(?:.*?)href=\"(.+?)\"(?:.*?) *?\/?>"
test_str = ("// Below ones must be parsed\n"
"<link rel=\"icon\" type=\"image/x-icon\" href=\"#\" />\n"
"<link rel=\"shortcut icon\" type=\"image/x-icon\" href=\"#\" />\n"
"<link rel=\"icon\" href=\"#\" type=\"image/x-icon\"/>\n"
"<link rel=\"shortcut icon\" href=\"#\" type=\"image/x-icon\"/>\n\n"
"// Below ones must be ignored\n"
"<link rel=\"search\" href=\"search.html\">\n"
"<link rel=\"help\" href=\"help.html\">")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.