package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<link +?(?:.*?)type="image\/x-icon"(?:.*?)href="(.+?)"(?:.*?) *?\/?>`)
var str = `// Below ones must be parsed
<link rel="icon" type="image/x-icon" href="#" />
<link rel="shortcut icon" type="image/x-icon" href="#" />
<link rel="icon" href="#" type="image/x-icon"/>
<link rel="shortcut icon" href="#" type="image/x-icon"/>
// Below ones must be ignored
<link rel="search" href="search.html">
<link rel="help" href="help.html">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}