#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^D(\d+)(?:\.(\d+)(?:\.(\d+))?)?"
Local $sString = "D1" & @CRLF & _
"D1sjdgf" & @CRLF & _
"D1.2" & @CRLF & _
"D1.2.3" & @CRLF & _
"D3.10.3x" & @CRLF & _
"D3.10.11"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")