import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^D(\\d+)(?:\\.(\\d+)(?:\\.(\\d+))?)?";
final String string = "D1\n"
+ "D1sjdgf\n"
+ "D1.2\n"
+ "D1.2.3\n"
+ "D3.10.3x\n"
+ "D3.10.11";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}