// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^D(\d+)(?:\.(\d+)(?:\.(\d+))?)?").unwrap();
let string = "D1
D1sjdgf
D1.2
D1.2.3
D3.10.3x
D3.10.11";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}