using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^D(\d+)(?:\.(\d+)(?:\.(\d+))?)?";
string input = @"D1
D1sjdgf
D1.2
D1.2.3
D3.10.3x
D3.10.11";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}