re = /^D(\d+)(?:\.(\d+)(?:\.(\d+))?)?/m
str = 'D1
D1sjdgf
D1.2
D1.2.3
D3.10.3x
D3.10.11'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end