const regex = new RegExp('^D(\\d+)(?:\\.(\\d+)(?:\\.(\\d+))?)?', 'gm')
const str = `D1
D1sjdgf
D1.2
D1.2.3
D3.10.3x
D3.10.11`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}