package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^D(\d+)(?:\.(\d+)(?:\.(\d+))?)?`)
var str = `D1
D1sjdgf
D1.2
D1.2.3
D3.10.3x
D3.10.11`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}