# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+\K\./|/gm;t' <<< "1. Wallbaum, H., S. Krank,
3. Levinson, H.S., Highways, people,
4. Mercier, J., Equity, social justice,
225. Lemp, J.D., et al.,
17. Chi, G. and B. Stone,"