const regex = /\d+\K\./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+\\K\\.', 'gm')
const str = `1. Wallbaum, H., S. Krank,
3. Levinson, H.S., Highways, people,
4. Mercier, J., Equity, social justice,
225. Lemp, J.D., et al.,
17. Chi, G. and B. Stone,`;
const subst = `|`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);