# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d+\K\."
test_str = ("1. Wallbaum, H., S. Krank, \n"
"3. Levinson, H.S., Highways, people,\n"
"4. Mercier, J., Equity, social justice, \n"
"225. Lemp, J.D., et al., \n"
"17. Chi, G. and B. Stone,")
subst = "|"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.