import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\K\\.";
final String string = "1. Wallbaum, H., S. Krank, \n"
+ "3. Levinson, H.S., Highways, people,\n"
+ "4. Mercier, J., Equity, social justice, \n"
+ "225. Lemp, J.D., et al., \n"
+ "17. Chi, G. and B. Stone,";
final String subst = "|";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}