using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\K\.";
string substitution = @"|";
string input = @"1. Wallbaum, H., S. Krank,
3. Levinson, H.S., Highways, people,
4. Mercier, J., Equity, social justice,
225. Lemp, J.D., et al.,
17. Chi, G. and B. Stone,";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}