re = /\d+\K\./m
str = '1. Wallbaum, H., S. Krank,
3. Levinson, H.S., Highways, people,
4. Mercier, J., Equity, social justice,
225. Lemp, J.D., et al.,
17. Chi, G. and B. Stone,'
subst = '|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result