$re = '/\d+\K\./m';
$str = '1. Wallbaum, H., S. Krank,
3. Levinson, H.S., Highways, people,
4. Mercier, J., Equity, social justice,
225. Lemp, J.D., et al.,
17. Chi, G. and B. Stone,';
$subst = "|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;