import Foundation
let pattern = #"\d+\K\."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1. Wallbaum, H., S. Krank,
3. Levinson, H.S., Highways, people,
4. Mercier, J., Equity, social justice,
225. Lemp, J.D., et al.,
17. Chi, G. and B. Stone,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)