# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?)\s*(1st|2d)($|\W).*/\1/gm;t' <<< "covid19 1st case
covid19 2d case
covid19 1std 1st case"