re = /^(.*?)\s*(1st|2d)($|\W).*/m
str = 'covid19 1st case
covid19 2d case
covid19 1std 1st case'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result