use strict;
my $str = 'covid19 1st case
covid19 2d case
covid19 1std 1st case';
my $regex = qr/^(.*?)\s*(1st|2d)($|\W).*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";