#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*?)\s*(1st|2d)($|\W).*"
Local $sString = "covid19 1st case" & @CRLF & _
"covid19 2d case" & @CRLF & _
"covid19 1std 1st case"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)