const regex = /^(.*?)\s*(1st|2d)($|\W).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)\\s*(1st|2d)($|\\W).*', 'gm')
const str = `covid19 1st case
covid19 2d case
covid19 1std 1st case`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);