$re = '/^(.*?)\s*(1st|2d)($|\W).*/m';
$str = 'covid19 1st case
covid19 2d case
covid19 1std 1st case';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;