using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)\s*(1st|2d)($|\W).*";
string substitution = @"\1";
string input = @"covid19 1st case
covid19 2d case
covid19 1std 1st case";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}