# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\]]+(\[|$)/2002-2021/;t' <<< "something (2002-2021) 2002-2021 something"