#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^\]]+(\[|$)"
Local $sString = "something (2002-2021) 2002-2021 something"
Local $sSubst = "2002-2021"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)