re = /[^\]]+(\[|$)/
str = 'something (2002-2021) 2002-2021 something'
subst = '2002-2021'
result = str.sub(re, subst)
# Print the result of the substitution
puts result