use strict;
my $str = 'something (2002-2021) 2002-2021 something';
my $regex = qr/[^\]]+(\[|$)/p;
my $subst = '2002-2021';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";