// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^\]]+(\[|$)").unwrap();
let string = "something (2002-2021) 2002-2021 something";
let substitution = "2002-2021";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}