$re = '/[^\]]+(\[|$)/';
$str = 'something (2002-2021) 2002-2021 something';
$subst = "2002-2021";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;