using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\]]+(\[|$)";
string substitution = @"2002-2021";
string input = @"something (2002-2021) 2002-2021 something";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}