const regex = new RegExp('[^\\]]+(\\[|$)', '')
const str = `something (2002-2021) 2002-2021 something`;
const subst = `2002-2021`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);