import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([^<>]*?)\"(?=[^>]+?<)";
final String string = "<p>This is a \"wonderful long text\". \"Another wonderful ong text\" At least it should be. Here we have a <a href=\"http://wwww.site-to-nowhere.com\" target=\"_blank\">link</a>.</p>\n";
final String subst = "\\<em\\>\\1\\<\\/em\\>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}