const regex = /"([^<>]*?)"(?=[^>]+?<)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"([^<>]*?)"(?=[^>]+?<)', 'g')
const str = `<p>This is a "wonderful long text". "Another wonderful ong text" At least it should be. Here we have a <a href="http://wwww.site-to-nowhere.com" target="_blank">link</a>.</p>
`;
const subst = `\<em\>\1\<\/em\>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);