import re
regex = re.compile(r"\"([^<>]*?)\"(?=[^>]+?<)")
test_str = ("<p>This is a \"wonderful long text\". \"Another wonderful ong text\" At least it should be. Here we have a <a href=\"http://wwww.site-to-nowhere.com\" target=\"_blank\">link</a>.</p>\n")
subst = "\\<em\\>\\1\\<\\/em\\>"
result = regex.sub(subst, test_str)
if result:
print(result)