use strict;
my $str = '<p>This is a "wonderful long text". "Another wonderful ong text" At least it should be. Here we have a <a href="http://wwww.site-to-nowhere.com" target="_blank">link</a>.</p>
';
my $regex = qr/"([^<>]*?)"(?=[^>]+?<)/p;
my $subst = '\\<em\\>\\1\\<\\/em\\>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";