re = /"([^<>]*?)"(?=[^>]+?<)/
str = '<p>This is a "wonderful long text". "Another wonderful ong text" At least it should be. Here we have a <a href="http://wwww.site-to-nowhere.com" target="_blank">link</a>.</p>
'
subst = '\\<em\\>\\1\\<\\/em\\>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result